-- JoachimHaase - 2011-06-15

IEEE P1076.1 Working Group - Table-Driven Modeling Project - Telco Meeting Minutes of June 14, 2011

Status: approved on August 22, 2011


Attendees

  • Alain Vachoux
  • Arpad Muranyi
  • Ernst Christen
  • Joachim Haase (chair, meeting convener, note taker)

Agenda

  • Call to order
  • Volunteer for minutes
  • Approval of agenda
  • Review and approve minutes from the last meeting
  • Discussion on action items of the last meeting
  • Next meeting
  • AOB
  • Adjourn

Call to order on June 14, 2011 at 8:05am PDT (17:05 CEST)

Joachim welcomes Ernst and starts presenting the meeting slides.

Volunteer for minutes

Joachim takes the notes.

Approval of agenda

Agenda unanimously approved.

Review and approve minutes from last meeting

Ernst agreed to approve the Minutes of the May 02, 2011 meeting.

Discussion on function interfaces

Ernst added comments to "Table-Driven Modeling in VHDL-AMS - Summary" (pdf) in the related document "Table-Driven Modeling in VHDL-AMS - Summary of problems" (pdf) where problems concerning use of VHDL-2002/VHDL-2008 were summarized.

It was agreed to start the test implementation using available implementations of VHDL simulation programs and adapt this later on to VHDL-201x requirements.

Alain distributed the following questions before the teleconf: "

  • I think that the PREPARE_TABLE_DATA function could be also used to perform checks such as to catch errors or misuses as mentioned in the top of page 5 or, e.g., specifying the TDM_RATIONAL interpolation method for real-valued interpolation.
  • The VHDL(-AMS) implementation of the PREPARE_TABLE_DATA function does not need to be "efficient", but only functionally correct. It is likely that there will be specific, more efficient, C implementations once the standard is out.
  • I'm still missing a user's view on how to use the package. Also, types such as TABLE_DATA_REAL would deserve more detailed descriptions, e.g., what are the roles of the record fields (not necessarily directly understandable from the field names).
  • Function names should rather be verbs, so I would propose to change INTERPOLATION to LOOKUP or something equivalent. Moreover, the function does also extrapolation, so lookup is more appropriate to me.
  • The TDM_EXTRAP method name is not well chosen, but I do not have another proposal for the moment. Moreover, I understand that the idea is to keep using the same interpolation method for extrapolated points, but then it seems that we are missing independent values.
  • A minor issue: avoid tab characters in source code. They can destroy the alignment and then the readability."

The result of the discussion was

  • The standard proposal shall describe the package header and usage of functions. This allows different implementation of the functions. The reference implementation of the package body shall provide a reference to check the functionality of the functions.
  • Ernst will check how specific requirements on the declaration of types TABLE_DATA_REAL and TABLE_DATA_COMPLEX can be avoided.
  • Better names for identifiers INTERPOLATION (e.g. LOOKUP) and TDM_EXTRAP must be found.

Next meeting

The next web meeting is planned on July 25, 2011 at 8am PDT or 17:00 CEST.

AOB

None.

Adjourn

Joachim adjourns the meeting at 18:10 CEST.

Action items

Joachim:

  • Update of the reference implementation

Ernst:

  • Check possibilities to „hide“ declaration of a type like TABLE_DATA_REAL in the standard proposal

Alain:

  • Proposal/Looking for test cases
Topic revision: r5 - 2016-01-24 - 02:35:21 - ErnstChristen
 
Copyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback